This allows using Puppet 7 with this module when strict dependency checking is enabled.
Without this change Kafo installers such as Foreman's Kafo installer will fail with this error message:
Puppet 7.5.0 does not meet requirements for puppet-make (>= 5.5.8 < 7.0.0)
Cannot continue due to incompatible version of Puppet.
Use --skip-puppet-version-check to disable this check.